UVA 1347(POJ 2677)Tour(双调欧几里得旅行商问题)

Tour

                Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

Download as PDF

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi, yi > . John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x -coordinates.

Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result.


Note: An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input

3 
1 1
2 3
3 1
4 
1 1 
2 3
3 1
4 2

Sample Output

6.47
7.89


题意:典型的动态规划例题。又叫做双调欧几里得旅行商问题。算法导论里面的题目。


思路:

dp[i][j] 表示从 i 到 1,再从1到j的距离。在这个路径上,点 1 到 Pmax(i,j) 点之间的所有点有且仅有经过一次。


dp[i][j] = dp[i-1][j] + dis(i,i-1);

dp[i][i-1] = min (dp[i][i-1], dp[i-1][j] + dis(i, j));


<span style="font-size:18px;">
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

const int INF = 1<<29;
const int MAXN = 1100;
const double PI = acos(-1.0);
const double e = 2.718281828459;
const double eps = 1e-8;
struct node
{
    double x;
    double y;
}a[MAXN];
double dp[MAXN][MAXN];

int cmp(node a, node b)
{
    return a.x < b.x;
}

double dist(int i, int j)
{
    return sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
}

int main()
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int n;
    while(cin>>n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf %lf", &a[i].x, &a[i].y);
        }
        sort(a+1, a+1+n, cmp);
        dp[2][1] = dist(1, 2);
        for(int i = 3; i <= n; i++)
        {
            dp[i][i-1] = INF*1.0;
            for(int j = 1; j < i-1; j++)
            {
                dp[i][i-1] = min(dp[i][i-1], dp[i-1][j]+dist(i, j));
                dp[i][j] = dp[i-1][j]+dist(i-1, i);
            }
        }
        double ans = INF*1.0;
        for(int i = 1; i < n; i++)
        {
            ans = min(ans, dp[n][i]+dist(n, i));
        }
        printf("%.2f\n", ans);
    }
    return 0;
}
</span>




1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值