HDU 1005

3 篇文章 0 订阅
2 篇文章 0 订阅

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 94119    Accepted Submission(s): 22487


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1021  1019  1009  1012 
 

Statistic |  Submit |  Discuss |  Note

思想:

由于n值太大,所以需要削减循环次数。注意到%7,所以f(n)的值只可能为0 1 2 3 4 5 6其中的某一个,由于f1=1, f2=1从而可以得到f3,f4,f5等等。

当其中后面的某连续两项同为1时,即:f(k-1) = 1, f(k) = 1  这时候又回到了f1, f2。

/*
	Title:HDU 1005 
	Author:Dojking
*/
#include <stdio.h>

int find(int A, int B)   //找出循环区间 
{
	int n = 0, f1 = 1, f2 = 1, f3 = 1;
	
	while (!(1 == f1 && 1 == f2) || !n)
	{
		f3 = (A*f2+B*f1)%7;
		f1 = f2;
		f2 = f3;
	//	printf("n =  %d,  f1 = %d,  f2 = %d\n",n, f1, f2);
		++n;
	}
	return n;
} 

int main()
{
	int i, mod, n, A, B, f1, f2, f3;
	
	while (scanf("%d%d%d", &A, &B, &n)==3 && (A && B && n))
	{
		mod = find(A, B);
		n %= mod;
	//	printf("mod = %d,  n = %d\n",mod, n);
		f3 = 1;
		f1 = 1;
		f2 = 1;
		for (i = 3; i <= n; ++i)   //求出f(n)的值,即f3 
		{
			f3 = (A*f2+B*f1)%7;
			f1 = f2;
			f2 = f3;
		}
		printf("%d\n",f3);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值