HCPC2014校赛训练赛 3 D.截取方案数 (3.15)

D.截取方案数
Time Limit: 1000 MS Memory Limit: 32768 K
Total Submit: 116 (50 users) Total Accepted: 38 (38 users) Special Judge: No
Description

给定一个模式串T,主串S,问:从S中截取T有多少种方案?

Input

有多组测试数据,对于每组测试数据,第一行是模式串T,第二行是主串S,数据中仅包含大小写字母和数字,模式串T长度不超过10^4, 主串S长度不超过10^5。

注意:数据是随机的。

Output

对于每组测试数据,输出一行,为截取方案数。

Sample Input
abc
abcdaabcab
abcd
abcdaabcab
aba
abababa
Sample Output
2
1
3



#include<cstdio>
#include<cstring>
char a[100005],b[100005];
int next[100005],n,m;
void getnext()
{
    int i=0,j=-1;
    next[0]=-1;
    while(b[i])
    {
        if(j==-1 || b[i]==b[j])
        {
            next[++i]=++j;
        }
        else
            j=next[j];
    }
}
int kmp()
{
    int i=0,j=0,tot=0;
    while(i<n)
    {
        if(j==-1 || a[i]==b[j])
        {
            i++;
            j++;
        }
        else
            j=next[j];
        if(j==m) tot++;
    }
    return tot;
}

int main()
{
    int t,i;
    while(scanf("%s",b)!=EOF)
    {
        scanf("%s",a);
        m=strlen(b);
        n=strlen(a);
        memset(next,0,sizeof(next));
        getnext();
        printf("%d\n",kmp());
    }
    return 0;
}


结果:


77790 D Accepted G++ 110ms 1476k 797B 2014-03-15 15:38:15


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值