截取方案数

截取方案数

Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 252(110 users) Total Accepted: 109(92 users) Rating: Special Judge: No

Description
给定一个模式串T,主串S,问:从S中截取T有多少种方案?
Input
有多组测试数据,对于每组测试数据,第一行是模式串T,第二行是主串S,数据中仅包含大小写字母和数字,模式串T长度不超过104,主串S长度不超过105。
注意:数据是随机的。
Output
对于每组测试数据,输出一行,为截取方案数。
Sample Input
abc
abcdaabcab
abcd
abcdaabcab
aba
abababa
Sample Output
2
1
3
直接套用KMP模板(不知道KMP是什么的自行GOOGLE)

#include<stdio.h>
#include<string.h>
char t[10008],s[100008];
int next[10008];
void kmp_pre(int len)
{
    int i,j;
    j=next[0]=-1;
    i=0;
    while(i<len)
    {
        while(-1!=j && t[i]!=t[j])j=next[j];
        next[++i]=++j;
    }
}
int kmpcount(int lent,int lens)
{
    int i,j;
    int ans=0;
    i=j=0;
    while(i<lens)
    {
        while(-1!=j&&s[i]!=t[j])j=next[j];
        i++;j++;
        if(j>=lent)
        {
            ans++;
            j=next[j];
        }
    }
    return ans;
}
int main()
{
    while(scanf("%s",t)!=EOF)
    {
        int lent=strlen(t);
        kmp_pre(lent);
        scanf("%s",s);
        int lens=strlen(s);
        printf("%d\n",kmpcount(lent,lens));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值