Cheapest Palindrome(区间DP)

Cheapest Palindrome
Time Limit: 2000MS  Memory Limit: 65536K
Total Submissions: 5458  Accepted: 2651

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:  N and  M 
Line 2: This line contains exactly  M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

Source

 

      题意:

      给出 N(1 ~ 26) 和 M (1 ~ 2000),后给出 M 长度的字符串,问如何增删其中的字母使其变成回文串,后给出 N 种字母 增加 和 删除分别的价钱,输出所需钱数最少使其变成回文串。

 

      思路:

      区间DP。设 dp [ i ] [ j ] 代表 i 到 j 使变成回文串的最少费用。所以:

      如果 s [ i ] == s [ j ],则说明不用进行操作,dp [ i ] [ j ] = dp [ i + 1 ] [ j - 1 ];

      否则,要不 对 s [ i ] 进行增删处理,或者对 s [ j ] 进行增删处理,而对于一个字母的增删操作只要取一个最小值就好了;

      所以 dp [ i ] [ j ] = min ( dp [ i + 1 ] [ j ] + cost [ s[ i ] ] , dp [ i ] [ j - 1 ] + cost [ s[ j ] ] )(dp [ i ] [ j ] 代表的是 i 到 j 已经变成回文串时候的最小费用,所以这个状态表示的已经是回文串了)。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

char s[2005];
int cost[30];
int dp[2005][2005];

int main() {
        int n, m;
        scanf("%d%d", &n, &m);
        scanf("%s", s);

        while (n--) {
                char c;
                int a, b;
                scanf(" %c%d%d", &c, &a, &b);
                cost[c - 'a'] = min(a, b);
        }

        memset(dp, 0, sizeof(dp));
        for (int j = 1; j < m; ++j) {
                for (int i = j - 1; i >= 0; --i) {
                        if (s[j] == s[i])  dp[i][j] = dp[i + 1][j - 1];
                        else {
                                int c1 = dp[i + 1][j] + cost[ s[i] - 'a' ];
                                int c2 = dp[i][j - 1] + cost[ s[j] - 'a' ];
                                dp[i][j] = min(c1, c2);
                        }
                }
        }

        printf("%d\n", dp[0][m - 1]);
        return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值