233 Matrix(矩阵快速幂)

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 553    Accepted Submission(s): 345


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

 

Output
For each case, output a n,m mod 10000007.
 

 

Sample Input
1 1
1
2 2
0 0
3 7
23 47 16
 

 

Sample Output

 

234
2799
72937
Hint

 

       题意:

       有个 N 行 M 列的矩阵,给出第一行和第一列的元素,根据 a [ i ] [ j ] = a [ i - 1 ] [ j ] + a [ i ] [ j - 1 ] 求出 a [ n ] [ m ] 元素是什么。

 

       思路:

       矩阵快速幂。详细题解明天再补回。记得要用 long long。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

typedef long long ll;
typedef vector<ll> vec;
typedef vector<vec> mat;

const ll MOD = 10000007;

ll n, m;

mat mul (mat a, mat b) {
    mat c(n + 2, vec(n + 2));

    for (ll i = 0; i < n + 2; ++i) {
        for (ll j = 0; j < n + 2; ++j) {
            for (ll k = 0; k < n + 2; ++k) {
                c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % MOD;
            }
        }
    }

    return c;
}

mat pow (mat a) {
    mat b(n + 2, vec(n + 2));
    for (ll i = 0; i < n + 2; ++i) {
        b[i][i] = 1;
    }

    while (m > 0) {
        if (m & 1) b = mul(b, a);
        a = mul(a, a);
        m >>= 1;
    }

    return b;
}

int main () {

    while (~scanf("%I64d%I64d", &n, &m)) {
        mat a(n + 2, vec(n + 2));
        mat b(n + 2, vec(1));

        a[0][0] = 10, a[0][1] = a[1][1] = 1;
        for (ll i = 2; i < n + 2; ++i) {
            for (ll j = 0; j < n + 2; ++j) {
                if (j <= i) a[i][j] = 1;
                if (!j) a[i][j] = 10;
            }
        }

        b[0][0] = 23, b[1][0] = 3;
        for (ll i = 0; i < n; ++i) {
            scanf("%I64d", &b[i + 2][0]);
            b[i + 2][0] %= MOD;
        }

        a = pow(a);
        b = mul(a, b);

        printf("%I64d\n", b[n + 1][0]);
    }

    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值