HDU-1394 zkw线段树 逆序数

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
解题思路:
ans:当前逆序数, low[i]:该位后面比其小的数的个数,up[i],比其大的…
每把一个数移到后面,ans=ans-low[i]+up[i], 又 up[i]=n-1-low[i];
ans=n-1-2* low[i];
又易知新的队首元素后面比其小的个数low[i] 即为新的队首元素的大小a[i]
ans=n-1-2* a[i];
代码:

#include<bits/stdc++.h>
#define maxn 5001
using namespace std;
inline int read(){
    	int x=0,f=0;char ch=getchar();
    	while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
    	while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
    	return f?-x:x;
}
int T[maxn<<2],n,m,q;
void build(){
	for(m=1;m<=n+1;m<<=1);
	for(int i=1;i<=n;++i)T[i+m]=0;
	for(int i=m-1;i;--i)T[i]=T[i<<1]+T[i<<1|1];
}
void update(int x,int val){
	T[x+=m]+=val;
	for(x>>=1;x;x>>=1)T[x]=T[x<<1]+T[x<<1|1];
}
int query(int l,int r){
	int L=0,R=0,ans=0;
	for(l=l+m-1,r=r+m+1;l^r^1;l>>=1,r>>=1){
		L+=T[l],R+=T[r];
		if(~l&1)ans+=T[l^1];
		if( r&1)ans+=T[r^1];
	}
	return ans;
}
int a[maxn];
int main(){
	while(~scanf("%d",&n)){
		build();
		int sum=0;
		for(int i=1;i<=n;++i){
			a[i]=read();
			sum+=query(a[i]+1,n);
			update(a[i],1);
		}
		int ans=sum;
		for(int i=1;i<=n;++i){
			sum+=n-1-a[i]-a[i];
			ans=min(sum,ans);
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值