Description
A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.
You are to help the administrator by reporting the number of bridges in the network after each new link is added.
Input
The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.
The last test case is followed by a line containing two zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.
Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output
Case 1:
1
0
Case 2:
2
0
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=2e5+5;
struct Edge{
int to,next;
Edge(){}
Edge(int to,int next):to(to),next(next){}
}E[N<<1];
int head[N],tot;
inline void addedge(int u,int v){
E[tot]=Edge(v,head[u]),head[u]=tot++;
}
int pre[N],bridge;
inline int F(int x){return pre[x]==-1?x:pre[x]=F(pre[x]);}
inline int Merge(int u,int v){
u=F(u),v=F(v);
if(u==v)return 0;
pre[u]=v;
return 1;
}
int low[N],dfn[N],sta[N],fa[N];
int id,top;
void tarjan(int u,int f){
int v,precnt=0;
low[u]=dfn[u]=++id,sta[top++]=u,fa[u]=f;
for(int i=head[u];~i;i=E[i].next){
v=E[i].to;
if(v==f&&!precnt){++precnt;continue;}
if(!dfn[v]){
tarjan(v,u);
low[u]=min(low[u],low[v]);
if(dfn[u]<low[v])++bridge;
else Merge(u,v);
}else low[u]=min(low[u],dfn[v]);
}
--top;
}
void lca(int u, int v){
if(F(u)==F(v))return;
if(dfn[v]<dfn[u])swap(u,v);
while(dfn[v]>dfn[u]){
if(Merge(v,fa[v]))--bridge;
v=fa[v];
}
while(u^v){
if(Merge(u,fa[u]))--bridge;
u=fa[u];
}
}
void init(){
memset(dfn,0,sizeof(dfn)),memset(head,-1,sizeof(head)),memset(pre,-1,sizeof(pre));
tot=bridge=id=top=0;
}
int n,m,cas,u,v,q;
int main(){
while(scanf("%d%d",&n,&m),n&&m){
init();
printf("Case %d:\n",++cas);
for(int i=1;i<=m;++i){
scanf("%d%d",&u,&v);
addedge(u,v),addedge(v,u);
}
tarjan(1,1);
scanf("%d",&q);
while(q--){
scanf("%d%d",&u,&v);
lca(u,v);
printf("%d\n",bridge);
}
putchar('\n');
}
return 0;
}