POJ-3190 贪心

Description
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A…B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.
Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input
Line 1: A single integer, N
Lines 2…N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.
Output
Line 1: The minimum number of stalls the barn must have.
Lines 2…N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5
1 10
2 4
3 6
5 8
4 7
Sample Output
4
1
2
3
2
4
Hint
Explanation of the sample:
Here’s a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 … c2>>>>>> c4>>>>>>>>> … …

Stall 3 … … c3>>>>>>>>> … … … …

Stall 4 … … … c5>>>>>>>>> … … …
Other outputs using the same number of stalls are possible.

POJ的C++版本好旧吖,连tuple都没有

按开始时间sort,用小根堆维护每个围栏 最后一头牛 最早结束时间

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#define Q(i,j,k) Tuple(i,j,k)
#define P(i,j) make_pair(i,j)
using namespace std;
typedef long long ll;
const int N=5e4+5;
struct Tuple{
	int i,j,k;
	Tuple(){}
	Tuple(int i,int j,int k):i(i),j(j),k(k){};
	bool operator<(const Tuple&t)const{
		return i^t.i?i<t.i:j<t.j;
	}
};
int n,cnt=1,l,r;
int a[N],ans[N];
vector<Tuple>cow;
priority_queue<pair<int,int> >q;
int main(){
	ios::sync_with_stdio(0);
	cin.tie(0),cout.tie(0);
	cin>>n;
	for(int i=0;i<n;++i)cin>>l>>r,cow.push_back(Q(l,r,i));
	sort(cow.begin(),cow.end());
	q.push(P(-cow[0].j,cnt));
	ans[cow[0].k]=cnt;
	for(int i=1;i<n;++i){
		int id=cow[i].k;
		if(-q.top().first<cow[i].i)ans[id]=q.top().second,q.pop(),q.push(P(-cow[i].j,ans[id]));
		else ans[id]=++cnt,q.push(P(-cow[i].j,cnt));
	}
	cout<<cnt<<'\n';
	for(int i=0;i<n;++i)cout<<ans[i]<<'\n';
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值