HDU-4699 对顶栈


Sample Input
8
I 2
I -1
I 1
Q 3
L
D
R
Q 2

Sample Output
2
3

一个栈存光标前的,一个存光标后的

#include<bits/stdc++.h>
using namespace std;
const int N=1e6+6;
stack<int>a,b;
char op;
int c,p,n;
int sum[N],f[N];
void update(int p,int c){
	sum[p]=sum[p-1]+c,f[p]=max(f[p-1],sum[p]);
}
int main(){
	ios::sync_with_stdio(0);
	cin.tie(0),cout.tie(0);
	while(cin>>n){
		f[0]=-1e9,p=0;
		while(!a.empty())a.pop();
		while(!b.empty())b.pop();
		while(n--){
			cin>>op;
			if(op=='I')cin>>c,a.push(c),update(++p,c);
			if(op=='D')a.pop(),--p;
			if(op=='L')if(!a.empty())b.push(a.top()),a.pop(),--p;
			if(op=='R')if(!b.empty())a.push(c=b.top()),b.pop(),update(++p,c);
			if(op=='Q')cin>>c,cout<<f[c]<<'\n';
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值