POJ-2248 迭代加深搜索

Description
An addition chain for n is an integer sequence with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.
Input
The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
Sample Input
5
7
12
15
77
0
Sample Output
1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

1.让m尽可能小,从大到小枚举i,j
2.m<=10,限制搜索深度,失败增加深度
3.不同i,j x[i]+x[j]可能相同,vis标记一下,避免重复搜

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#define clr(x) memset(x,0,sizeof(x))
using namespace std;
typedef long long ll;
const int N=107;
int n,x[N],vis[N];
int dfs(int now,int dep,int last){
	if(x[now]==n)return 1;
	if(now>=dep)return 0;
	for(int i=now;i;--i)
		for(int j=i,s;s=x[i]+x[j],j;--j)if(!vis[s])
			if(s>=last){
				vis[x[now+1]=s]=1;
				if(dfs(now+1,dep,s))return 1;
				vis[s]=0;
			}else break;
	return 0;
}
int main(){
	x[1]=1,x[2]=2;
	while(scanf("%d",&n),n){
		if(n<3){for(int i=1;i<=n;++i)printf("%d ",x[i]);putchar('\n');continue;}
		int k=3;
		if(n>16)k=6;
		for(;clr(vis),k<11;++k)if(dfs(2,k,3))break;
		for(int i=1;i<=k;++i)printf("%d ",x[i]);
		putchar('\n');
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值