uva253

http://vjudge.net/problem/viewProblem.action?id=19116


Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

Download as PDF


 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

picture21

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE

设两个正方体是 c1, c2, 保持 c1 不变,枚举 c1 的相邻的三个面,和 c2 的6个面依次对比,如果这个面和其中一个面相同,并且这两个面的对面也对应相同,那么就把 c2 的这两个面标记为字符 ‘0’ ,防止以后再次用到这两个面。如果对于 c1 的这三个面的其中一个面,在 c2 中找不到符合条件(即两个面相同并且对面也相同)的,就退出循环,说明这两个正方体不相同,否则,这两个正方体相同.


#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int i, j;
    char c1[7], c2[7], str[13];
    while(scanf("%s", str)!=EOF)
    {
        for (i=0; i<6; i++)
            c1[i]=str[i];
        for (; i<12; i++)
            c2[i-6]=str[i];
        int ct;
        for (i=0; i<3; i++)
        {
            ct=0;
            for (j=0; j<6; j++)
            {
                if (c1[i] == c2[j] && c1[5-i] == c2[5-j])
                {
                    ct=1;
                    c2[j]='0';
                    c2[5-j]='0';
                    break;
                }
            }
            if (!ct) break;
        }
        if (!ct)
        {
            cout << "FALSE" << endl;
            continue;
        }
        cout << "TRUE" << endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值