uva(10344)

http://vjudge.net/vjudge/problem/viewProblem.action?id=19643


Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

[Submit]   [Go Back]   [Status]  

Description

Download as PDF

Problem I

23 Out of 5

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Your task is to write a program that can decide whether you can find an arithmetic expression consisting of five given numbers (1<=i<=5) that will yield the value 23.
For this problem we will only consider arithmetic expressions of the following from:

            
where : {1,2,3,4,5} -> {1,2,3,4,5} is a bijective function 
and �{+,-,*} (1<=i<=4)     

Input

The Input consists of 5-Tupels of positive Integers, each between 1 and 50.
Input is terminated by a line containing five zero's. This line should not be processed.

Output

For each 5-Tupel print "Possible" (without quotes) if their exists an arithmetic expression (as described above) that yields 23. Otherwise print "Impossible".

Sample Input

1 1 1 1 1 
1 2 3 4 5 
2 3 5 7 11 
0 0 0 0 0 

Sample Output

Impossible 
Possible 
Possible 
用第一个的话会超时,中间进行了好多重复的计算

的二个每次利用前一次的结果.

暴力也要讲方法.


#include <iostream>
#include<cstring>
#include<cstdio>

using namespace std;
int a[6],A[6],flag,vis[6],v[6];
char b[]= {"*-+"},B[6];

void dfs1(int cur)
{
    int t;
    if(flag) return ;
    else if(cur==5)
    {
        t=A[0];
        for(int i=0; i<4; i++)
        {
            switch (B[i])
            {
            case '+':t=t+A[i+1];break;
            case '-':t=t-A[i+1];break;
            case '*':t=t*A[i+1];break;
            default:break;
            }
            if(t>154) break;
        }
        if(t==23)  flag=1;
    }
    else for(int i=0; i<3; i++)
        {
            B[cur]=b[i];
            dfs1(cur+1);
        }
}
void solve(int cur, int sum)
{
    if(cur == 5)
    {
        if(sum == 23)
            flag = 1;
        return ;
    }
    solve(cur + 1, sum + A[cur]);
    if(flag)
        return;
    solve(cur + 1, sum - A[cur]);
    if(flag)
        return;
    solve(cur + 1, sum * A[cur]);
    if(flag)
        return;
}
void dfs(int cur)
{
    if(flag)
        return ;
    else if(cur==5)
    {
       dfs1(0);
//     solve(1,A[0]);
    }
    else for(int i=0; i<5; i++)
        {
            if(!v[i])
            {
                v[i]=1;
                A[cur]=a[i];
                dfs(cur+1);
                v[i]=0;
            }
        }
}

int main()
{
    freopen("in.txt","r",stdin);
    while(scanf("%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4]))
    {
        if(a[0]==0) break;
        dfs(0);
        if(flag)  cout<<"Possible"<<endl;
        else  cout<<"Impossible"<<endl;
        memset(A,0,sizeof(A));
        memset(B,0,sizeof(B));
        memset(v,0,sizeof(v));
        memset(vis,0,sizeof(vis));
        flag=0;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值