XTU OJ 1207 Welcome to XTCPC (字符串签到题)

11 篇文章 0 订阅
10 篇文章 0 订阅
Problem Description

Welcome to XTCPC! XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not. Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases. For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input
3
XTCPC
CCC
XXXXTTTTCCCCPPPCCC


Sample Output
Case 1: Yes
Case 2: No
Case 3: Yes

签到题,一道字符串的水题,这种题目还是要争取1A,不要耗费太多的时间;
#include <cstdio>
#include <cstring>
char s[101];
char c[6]={'X','T','C','P','C'};
int main()
{
    int t,i,j,id;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        id=0;
        scanf("%s",s);
        for(j=0;j<strlen(s);j++)
        {
            if(s[j]==c[id])
                id++;
        }
        if(id==5)
            printf("Case %d: Yes\n",i);
        else
            printf("Case %d: No\n",i);
    }
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值