poj 1163 The Triangle (动态规划)

28 篇文章 0 订阅
13 篇文章 0 订阅
The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37778 Accepted: 22685

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source


动态规划基础题,主要掌握这种层层递推的思想,由最后一层往上递推;
题意就是从顶层的数字开始,有两个方向开始走,走到底层,输出最大的距离;
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=101;
int dp[maxn][maxn],a[maxn][maxn];
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
        scanf("%d",&a[i][j]);
    for(i=1;i<=n;i++)
        dp[n][i]=a[n][i];
    for(i=n-1;i>=0;i--)
        for(j=1;j<=i;j++)
        dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];//往上递推
    printf("%d\n",dp[1][1]);
    return 0;
}
还有一种节约内存的写法;
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=101;
int a[maxn][maxn];
int *dp;
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
        scanf("%d",&a[i][j]);
        dp=a[n];
    for(i=n-1;i>=0;i--)
        for(j=1;j<=i;j++)
        dp[j]=max(dp[j],dp[j+1])+a[i][j];
    printf("%d\n",dp[1]);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值