hdu1242

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1242

题目:

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14614    Accepted Submission(s): 5300


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1072  1241  1253  1372 
这个题目最开始是没有说清楚。。请看。。

Angel's friends

结果单组就可以过了。。。还有就是这个题目因为碰到守卫会出现时间的不同变化。。所以我运用了剪枝。。。如果步数大于已经确定的步数,则不需要入队。。这个还是挺高效的。。0ms。。。。代码如下:

#include<cstdio>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f
const int maxn=200+10;
using namespace std;
int dx[4]={0,0,-1,1};
int dy[4]={-1,1,0,0};
int step[maxn][maxn];
int n,m;
int sum;
char map[maxn][maxn];

struct Map
{
    int x,y;
    int time;
};
queue<Map>q;
Map start,end;

int check(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m)
      return 1;
    return 0;
}

int bfs()
{
    Map current,next;
    step[start.x][start.y]=0;
    q.push(start);
    while(!q.empty())
    {
        current=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next.x=current.x+dx[i];
            next.y=current.y+dy[i];
            next.time=current.time+1;
            if(map[next.x][next.y]=='x')
               next.time++;
            if(check(next.x,next.y)&&map[next.x][next.y]!='#'&&next.time<step[next.x][next.y])
            {
                step[next.x][next.y]=next.time;
                q.push(next);
            }
        }
    }
        return step[end.x][end.y];
}

int main()
{
    int sx,sy;
    char str[maxn];
    int pos=0,ans=INF;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
       //memset(vis,false,sizeof(vis));
       memset(step,INF,sizeof(step));
       for(int i=1;i<=n;i++)
       {
          scanf("%s",str);
          for(int j=1;j<=m;j++)
          {
              map[i][j]=str[j-1];
              if(map[i][j]=='r') start.x=i,start.y=j,start.time=0;
              if(map[i][j]=='a') end.x=i,end.y=j;
          }
       }
     ans=bfs();
     if(ans!=INF)
          printf("%d\n",ans);
     else
          printf("Poor ANGEL has to stay in the prison all his life.\n");
     }
     return 0;
}
/*
2 2
r.
.a
4 4
a...
#.xx
.#r.
..##

*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值