poj3687Labeling Balls(反向拓扑+优先队列)

题目链接:

题意:就是给了m个限制条件,然后形式是啊a,b就是说编号为a的小球比编号为b的小球青,最后输出字典序最小的序列出来。

思路:如果正常的正向建图的话,有可能得到的不是字典序最小的序列。。比如有这样一个例子1->5->4,6->2->3,如果正向建图得到的序列将会是
5 2 1 3 4 6,,而正确的序列式怎么感觉碰到一些题目按字典序都要逆向枚举啊。。1 3 
4 6 5 2.。所以要反向拓扑。。

题目:

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10732 Accepted: 3045

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source


代码为:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstring>
using  namespace std;

const int maxn=200+10;
vector<int>vec[maxn];
int in[maxn],map[maxn][maxn],ans[maxn];
int t,n,m,u,v;

void topo()
{
    priority_queue<int>Q;
    memset(ans,0,sizeof(ans));
    while(!Q.empty())  Q.pop();
    int cal=n,id=0,flag=0;
    for(int i=1;i<=n;i++)
    {
        if(in[i]==0)
          Q.push(i);
    }
    while(!Q.empty())
    {
        int temp=Q.top();
        Q.pop();
        ans[temp]=cal--;
        for(int i=0;i<vec[temp].size();i++)
        {
            if(--in[vec[temp][i]]==0)
                Q.push(vec[temp][i]);
        }
    }
    if(cal!=0)
        {
            cout<<"-1"<<endl;
            return;
        }
    for(int i=1;i<n;i++)
        printf("%d ",ans[i]);
    printf("%d\n",ans[n]);
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        {
            in[i]=0;
            vec[i].clear();
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            if(map[u][v]==0)
            {
                map[u][v]=1;
                vec[v].push_back(u);
                in[u]++;
            }
        }
        topo();
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值