计软对抗赛之 Easy的题

Easy的题

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

YZL说她的线代很好,但是我们大家都不服啊,这坚决不能忍啊。。连我这上学期把所有能挂的科目都挂了的学渣渣都表示不服。。。于是我们一起出了个看似是矩阵或者行列式的题目给她,让她来做。她一看惊呼“so easy!”,然后。。。就没然后了。。只是从她嘴里知道她现在突然变得特别忙。。。。(赤果果的借口!)她想要找你来帮她做一下,但是用脚趾头想想都知道你肯定不想帮她做,但是聪明的你一眼就看出了里边的规律,而且编程能力很强的你,可不可以写个程序来算呢,就可以不用手工来帮她算了。为了给YZL增加难度,于是给她出的英文题(现在发现确实是高估了她了。。。)。

The dot product of two integer number vectors x and y of size n is the sum of the products of the corresponding components of the vectors. The unusual square of an n × n square matrix A is defined as the sum of n dot products. The i-th of them is the dot product of the i-th row vector and the i-th column vector in the matrix A.Fortunately for Chris, he has to work only in GF(2)! This means that all operations (addition, multiplication) are calculated modulo 2. In fact, the matrix A is binary: each element of A is either 0 or 1. For example, consider the following matrix A:
 
The unusual square of A is equal to (1·1 + 1·0 + 1·1) + (0·1 + 1·1 + 1·0) + (1·1 + 0·1 + 0·0) = 0 + 1 + 1 = 0.However, there is much more to the homework. Chris has to process q queries; each query can be one of the following:
given a row index i, flip all the values in the i-th row in A;
 
given a column index i, flip all the values in the i-th column in A;
 
find the unusual square of A.
To flip a bit value w means to change it to 1 - w, i.e., 1 changes to 0 and 0 changes to 1.Given the initial matrix A, output the answers for each query of the third type! Can you solve Chris's homework?

输入

The first line of input contains an integer n (1 ≤ n ≤ 1000), the number of rows and the number of columns in the matrix A. The next n lines describe the matrix: the i-th line contains n space-separated bits and describes the i-th row of A. The j-th number of the i-th line aij (0 ≤ aij ≤ 1) is the element on the intersection of the i-th row and the j-th column of A.
 
The next line of input contains an integer q (1 ≤ q ≤ 106), the number of queries. Each of the next q lines describes a single query, which can be one of the following:
 
1 i — flip the values of the i-th row;
2 i — flip the values of the i-th column;
3 — output the unusual square of A.
Note: since the size of the input and output could be very large, don't use slow output techniques in your language. For example, do not use input and output streams (cin, cout) in C++.

输出

Let the number of the 3rd type queries in the input be m. Output a single string s of length m, where the i-th symbol of s is the value of the unusual square of A for the i-th query of the 3rd type as it appears in the input.

示例输入

3
1 1 1
0 1 1
1 0 0
12
3
2 3
3
2 2
2 2
1 3
3
3
1 2
2 1
1 1
3

示例输出

01001
 
   
 
   
比赛时没读懂 后来听别人讲的 先是输入一个n*n的矩阵,然后根据矩阵的乘法求出其结果,对2取余 ,如果输入3,则输出结果,否则 输入两个数 a[i][k]变为其相反的数 AC代码如下
#include <iostream>
#include <stdio.h>
using namespace std;
 int a[1001][1001];
int main()
{

    int n,i,k;
    while(~scanf("%d",&n))
    {
        int sum=0;
        int m,r,e;
        for(i=1;i<=n;i++)
            for(k=1;k<=n;k++)
               scanf("%d",&a[i][k]);
      for(i=1;i<=n;i++)
            for(k=1;k<=n;k++)
                sum+=a[i][k]*a[k][i];

            sum=sum%2;
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&r);
            if(r==3)
                printf("%d",sum);
                else
                {
                    scanf("%d",&e);
                    sum=1-sum;
                }
        }

    }
    return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值