poj 2299 Ultra-QuickSort (归并排序模板)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 49098 Accepted: 17958

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6

0

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 500003;
long long n;
long long a[maxn], c[maxn], cnt;

void mergeSort(int l, int r)
{
    long long mid, i, j, tmp;
    if(r >l+1)
    {
        mid = (l+r)/2;
        mergeSort(l, mid);
        mergeSort(mid, r);
        tmp = l;
        for(i=l, j=mid; i<mid && j<r; )
        {
            if(a[i]>a[j])
            {
                c[tmp++] = a[j++];
                cnt += mid-i;
            }
            else c[tmp++] = a[i++];
        }
        if(j<r) for(; j<r; j++) c[tmp++] = a[j];
        else for(; i<mid; i++) c[tmp++] = a[i];
        for(i=l; i<r; i++) a[i] = c[i];
    }
}

int main()
{
    while(~scanf("%lld", &n) ,n )
    {
        for(int k=0; k<n; k++)
            scanf("%lld", &a[k]);
        cnt = 0;
        mergeSort(0, n);
        printf("%lld\n", cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值