POJ 2828 Buy Tickets(线段树单点更新维护)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 14304 Accepted: 7157

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243
 
题目大意为,开始有一个空的序列,有n个人要插进去,每个人都有一个属性值(p[i],v[i] ,, 其中p[i]是说这个人要插在p[i]个人的后面,v[i]是这个人的属性值),最后让你从队首开始输出每个人的属性值。。
在用线段树处理数据的时候要倒着来,因为后面的人会影响前面人的顺序,这样保证每次插入的位置不会再变化。。
节点代表这个区间空的位置数,在插入的时候,将插入的人放在p[i]+1的位置,相应的节点值要-1,在前面的人也要插到这个位置时,因为这个位置被占了,所以前面的人位置就会往后一个。。
 
#include <iostream>
#include <stdlib.h>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 200010;
int q[N],s[N*4];  //节点序号,区间长度、即空的位置数目
int p[N],v[N];    //每个人要插的位置和属性值
void build(int rt,int left,int right)
{
    s[rt]=right-left+1;      // 记录区间的长度
    if(left==right)
    {
        q[left]=rt;
        return ;
    }
    int mid=(left+right)/2;
    build(rt*2,left,mid);
    build(rt*2+1, mid+1,right);
}
int Find(int ss,int rt,int l,int r)
{
    if(l==r)
        return l;
    int mid=(r+l)/2;
    if(s[rt*2]>=ss)          //左子树的空位数多于要插的位置,递归左子树,反之右子树
        return Find(ss,rt*2,l,mid);
    else return Find(ss-s[rt*2],rt*2+1,mid+1,r);
}
void change(int i)
{
    while(i>0)           //从叶节点向上,所对应节点数值-1
    {
        s[i]--;
        i=i/2;
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int ans[N];
        for(int i=1; i<=n; i++)
            scanf("%d%d",&p[i],&v[i]);
        build(1,1,n);           //建树
        for(int i=n; i>=1; i--)
        {
            int t=Find(p[i]+1,1,1,n);      //确定插得位置编号
            ans[t]=i;                    //ans[t]表示插到位置t的编号
            change(q[t]);                //动态维护
        }
        for(int i=1; i<n; i++)
            printf("%d ",v[ans[i]]);
        printf("%d\n",v[ans[n]]);
    }
    return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值