POJ 1017 Packets(构造模拟)

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45405 Accepted: 15338

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 
给出1*1,2*2,3*3,4*4,5*5,6*6六种产品的尺寸,包装盒的高度于产品的相同,问最少用多少6*6的包装盒。
按照尺寸递减的顺序放:
6*6:正好可以放一个
5*5:放入6*6的包装盒后,剩下的用1*1的填充
4*4:放入6*6的包装盒后,剩下的先用2*2的填充,用没了用1*1的填充
3*3:一个6*6的包装盒可以放4个,剩下的也是先用2*2填充,然后1*1的
2*2:一个6*6的包装盒可以放9个,剩下的用1*1的填充
1*1:一个6*6的包装盒可以放36个
六种产品的数量分别为a1,a2,a3,a4,a5,a6,需要包装盒数量ans,
则放入6*6,5*5,4*4,3*3,后 ans = a6+a5+a4+a3/4;
这时需要2*2去填的数量x2 = a4*5(每个4*4需要用5个2*2去填充) + s[a3%4] (s[0]=0,s[1]=5,s[2]=3,s[3]=1,在平面上画一下很容易得出) ,这时如果 a2>x2,说明2*2的还有剩余,所以ans+=(a2-x2+8)/9;
最后需要用1*1去填的数量为x1=ans*36-a6*36+a5*25+a4*16+a3*9+a2*4,这时如果 a1>x1,说明1*1的还有剩余,所以 ans+=(a1-x1+35)/36,ans即为最后的结果
#include <iostream>
#include <cstring>
#include <cstdio>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int main()
{
   int a[10];
   int s[4]={0,5,3,1};   //3*3剩下(0,1,2,3)个对应需要2*2的数量
   while(1)
   {
       int sum=0;
       for(int i=1;i<=6;i++)
       {
          cin>>a[i];
          sum+=a[i];
       }
       if(!sum) break;
       int ans=a[6]+a[5]+a[4]+(3+a[3])/4;
       int x2=a[4]*5 + s[a[3]%4];
       if(a[2]>x2)                        //2*2还有剩余的情况
        ans+=(a[2]-x2+8)/9;
       int x1=ans*36-a[6]*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;
       if(a[1]>x1)                         //1*1还有剩余的情况
        ans+=(a[1]-x1+35)/36;
       cout<<ans<<endl;
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值