POJ 1035 Spell checker(字符串处理)

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20082 Accepted: 7366

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
 
第一个#前面是字典里的单词,两个#之间的单词为查询的单词,如果查询的单词s能直接在字典中找到,输出"s is correc"
如果查询的单词可以通过字典中的单词替换,增加,删除一个字母,把字典可能的单词全部输出,否则输出空。
一个水题,直接暴就可以了。。。。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <stdlib.h>
#include <algorithm>
#define inf 0x7fffffff
#define N 10010
using namespace std;
char s[N][30];
char a[N][30];
bool deng(char e[],char r[],int m)           //判断替换一字母的情况
{
    int ss=0;
    for(int i=0; i<m; i++)
    {
        if(r[i]!=e[i])
        {
            ss++;
            if(ss>=2)
                return false;
        }
    }
    return true;
}
bool bud(char e[],char r[],int m)          //判断增加或删除一字母的情况
{
    int k=0,ss=0;
    for(int i=0; i<m; i++)
    {
        if(e[i]!=r[k])
        {
            ss++;
            if(ss>=2)
                return false;
        }
        else k++;
    }
    return true;
}
void prin(int ns,int na)
{
    int b[N];
    memset(b,0,sizeof(b));
    for(int i=0; i<ns; i++)
        for(int j=0; j<na; j++)
        {
            if(strcmp(s[i],a[j])==0)
            {
                b[i]=1;
                break;
            }
        }
    for(int i=0; i<ns; i++)
    {
        if(b[i])
        {
            printf("%s is correct\n",s[i]);
            continue;
        }
        int flag=0;
        int kk=0;
        for(int j=0; j<na; j++)
        {
            int lens=strlen(s[i]);
            int lena=strlen(a[j]);
            if(lena==lens)
            {
                if(deng(s[i],a[j],lens))
                {
                    if(!kk)
                    {
                        printf("%s:",s[i]);
                        kk++;
                    }
                    printf(" %s",a[j]);
                    flag=1;
                }
            }
            else if(lena==lens-1)
            {
                if(bud(s[i],a[j],lens))
                {
                    if(!kk)
                    {
                        printf("%s:",s[i]);
                        kk++;
                    }
                    printf(" %s",a[j]);
                    flag=1;
                }

            }
            else if(lena==lens+1)
            {
                if(bud(a[j],s[i],lena))
                {
                    if(!kk)
                    {
                        printf("%s:",s[i]);
                        kk++;
                    }
                    printf(" %s",a[j]);
                    flag=1;
                }
            }

        }
        if(!flag) printf("%s:",s[i]);
        printf("\n");
    }
}
int  main()
{
    int s1=0,a1=0;
    char t[30];
    int flag=0;
    while(~scanf("%s",t))
    {
        if(strcmp(t,"#")==0)
        {
            if(!flag)
                flag=1;
            else if(flag)
            {
                flag=0;
                prin(s1,a1);
            }
        }
        else if(!flag) strcpy(a[a1++],t);
        else if(flag) strcpy(s[s1++],t);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值