BoneCollector-01背包

问题来源:hdu-2602

Bone Collector


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

源代码:
#include<stdio.h>
#include<string.h>
#define MAX 1002

int  V , N , pack[MAX];
int  volume[MAX] , value[MAX];

int Max( int a , int b ){ return a >= b ? a : b; }
int ZeroOnePack( void );    //0-1背包

int main( ){
    int T;

    scanf("%d",&T);

    while( T-- ){
        scanf("%d%d",&N,&V);

        for( int i=0 ; i<N ; i++ )
            scanf("%d",&value[i]);

        for( int i=0 ; i<N ; i++ )
            scanf("%d",&volume[i]);

        printf("%d\n",ZeroOnePack());
    }

    return 0;
}


int ZeroOnePack( void ){
    memset( pack , 0  , sizeof( pack ) );
    //初始化为0是背包不要求放满的情况
    //当背包要求放满的话,需要初始化为-INF(初始都不满),pack[0]=0(理解为0容量的背包已经满了)

    for( int i=0 ; i<N ; i++ )
        for( int j=V ; j-volume[i]>=0 ; j-- )    //01背包从后向前dp,完全背包从前向后dp,保证了i物品不会被选择多次
            pack[j] = Max( pack[j] , pack[j-volume[i]]+value[i] );
    return pack[V];    //返回背包能容纳的物品最大价值
}

代码分析:该题是很明显的背包题,具体是0-1背包,即每个物品最多只能选择一次,所以ZeroOnePack函数的第二层从后往前循环保证了这一点,若从头往后循环则是完全背包问题。同时注意初始化的时候全都赋值为0是不要求放满的情况,若需要放满,则赋值为pack[i]=-INF&&pack[0]=0;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值