输入10个数字,然后逆序输出

 

Description

输入10个数字,然后逆序输出。

Input

十个整数

Output

逆序输出,空格分开

Sample Input

1 2 3 4 5 6 7 8 9 0

Sample Output

0 9 8 7 6 5 4 3 2 1

HINT

主函数已给定如下,提交时不需要包含下述主函数
/* C++
代码 */
int main()
{
    void revert(int *,int);
    const int N=10;
    int a[N],i;
    for(i=0; i<N; i++)
        cin>>a[i];
    revert(a,N);
    return 0;
}

#include <iostream>
using namespace std;
void revert(int *a,int x);
int main()

{

    void revert(int *,int);

    const int N=10;

    int a[N],i;

    for(i=0; i<N; i++)

        cin>>a[i];

    revert(a,N);

    return 0;

}

void revert(int *a,int x)
{
	int *m=a,t,i;
    for(i=0;i<x/2;i++)
	{
		t=*(m+i);
		*(m+i)=*(m+x-1-i);
		*(m+x-1-i)=t;
	}
	for(;m<a+x-1;m++)
		cout<<*m<<' ';
	cout<<*m;
}


  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值