实验11-2-2 学生成绩链表处理 (20分)

本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。

函数接口定义:
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:

struct stud_node {
int num; /学号/
char name[20]; /姓名/
int score; /成绩/
struct stud_node *next; /指向下个结点的指针/
};
输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。

函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};

struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );

int main()
{
    int min_score;
    struct stud_node *p, *head = NULL;

    head = createlist();
    scanf("%d", &min_score);
    head = deletelist(head, min_score);
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:
1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80
输出样例:
2 wang 80
4 zhao 85

 struct stud_node *createlist(){
	int temp;
	struct stud_node *p,*head=NULL,*tail=NULL;
	scanf("%d",&temp);
	while(temp){
		p=(struct stud_node*)malloc(sizeof(struct stud_node));
		p->num=temp;
		scanf("%s %d",p->name,&p->score);
		if(head==NULL){
			head=tail=p;
		}else{
			tail->next=p;
			tail=tail->next;
		}
		tail->next=NULL;
		scanf("%d",&temp);
	}
	return head;
}
struct stud_node *deletelist( struct stud_node *head, int min_score ){
	struct stud_node *p,*tail;
	while(head!=NULL&&head->score<min_score) head=head->next;//判空一定要写在&&的左边,因为如果为空,读head->score会报错 
	if(head==NULL) return NULL;
	tail=head;
	p=tail->next;
	while(p!=NULL){
		if(p->score<min_score){
			tail->next=p->next;
			free(p);		//做题时,我多写了一句tail=tail->next;导致后面p=tail->next执行后的结果p漏掉了一个结点 
		}else tail=p;
		p=tail->next;
	}
	return head;
}

因为这两个错误,搞了一个晚上,虽然没有完成别的任务,但是多少还是有收获的

  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值