实验11-2-4 删除单链表偶数节点 (20分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7

struct ListNode *createlist(){
	struct ListNode *head=NULL,*tail,*p;
	int num;
	scanf("%d",&num);
	while(num!=-1){
		p=(struct ListNode*)malloc(sizeof(struct ListNode));
		p->data=num;
		if(head==NULL) head=tail=p;
		else{
			tail->next=p;
			tail=p;
		}
		scanf("%d",&num);
	}
	tail->next=NULL;
	return head;
}
struct ListNode *deleteeven( struct ListNode *head ){
	struct ListNode *tail,*p;
	while(head&&head->data%2==0) {
		p=head;
		head=head->next;
		free(p);
	}
	if(head==NULL) return NULL;
	tail=head;
	p=tail->next;
	while(p!=NULL){
		if(p->data%2==0){
			tail->next=p->next;
			free(p);
		}else tail=p;		
		p=tail->next;
	}
	return head;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值