HDU1021

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37739    Accepted Submission(s): 18208


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay
 
方法:
数及对应的规律用(int型表示)
0 1  2  3  4  

5 6 7 ......41 427 11 18 29 47 76 123 199......1568397607 负值(超出最大整数值,溢出)考虑溢出问题。1、直接法 f(0) = 7%3;f(1) = 11%3;i>=2时f(i) = (f(i-1)%3+f(i-2)%3)%3;2.数字规律前几位数及其余数 0 1 2 3 4 5 6 7 8 数7 11 18 29 47 76 123 199 322余数1 2 0 2 2 1 0 1 1可知观察每四个为一组中第三个为yes即 i%4==2或(i-2)%4==0求即可
#include<stdio.h>
int main()
{
	int i,n;
	while(scanf("%d",&n)!=EOF)
	{
		if((n-2)%4==0||n%4==2)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值