PAT 甲 1065 A+B and C

Given three integers A, B and C in [−2^​63, 2^63], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题意:
给定三个整数 A,B,C,请你判断 A+B>C 是否成立。
注意数据范围[−2^​63, 2^63]
思路:
溢出 a、b均大于0,a+b<0
溢出a、b均小于0,a+b>=0
C++:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main(){
    int t,i=0;
    cin>>t;
    while(t--){
        LL a,b,c;
        cin>>a>>b>>c;
        LL d=a+b;
        int flag=1;
        if(a>0&&b>0&&d<0) flag=0; //溢出 a、b均大于0,a+b<0
        else if(a<0&&b<0&&d>=0) flag=1;//溢出a、b均小于0,a+b>=0
        else if(d>c) flag=0;
        if(flag==1) cout<<"Case #"<<++i<<": false"<<endl;
        else cout<<"Case #"<<++i<<": true"<<endl;
        
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值