PAT 甲 1019 普通回文数 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a a​i as ∑​i=0​k ​​ (a ​i ​​ b ​i ​​ )
​​ ). Here, as usual, 0≤a ​i ​​ <b
for all i and a
​k
​​ is non-zero. Then N is palindromic if and only if a ​i ​​ =a ​k−i
​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10 ​9 ​​
​​ is the decimal number and 2≤b≤10 ​9
​​ is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form a ​k ​​ a ​k−1 ​​ ... a ​0 ​​
​​ ". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题意:
一个数字如果从前往后读和从后往前读都完全一样,那么这个数就是回文数。
例如,1234321 就是一个回文数。
所有的一位数字都是回文数。
我们一般都是在十进制下考虑回文,但是回文这一概念也可以应用于其他进制下的数字中。
一个整数 N,在 b 进制下,共有 k+1 位,其中第 i 位的数字为 ai,(0≤i≤k),那么 N=∑ki=0(aibi)。
一般来说,0≤ai<b,并且 ak≠0。
如果对于任意 i,满足 ai=ak−i,那么 N 在 b 进制下就是一个回文数。
0 在任何进制下都表示为 0,且都视为是一个回文数。
现在给定一个整数 N,请你判断它在 b 进制的表示下,是否是一个回文数。
思路:

//十进制----》d进制:

int ans[31],num=0;        
do{
            ans[num++]=sum%d;
            sum=sum/d;
    }while(sum!=0);
    
 // d进制----》十进制:
int y=0,product=1;
while(x!=0){
    y=y+(x%10)*product;//x%10为了每次获取x的个位数
    x=x/10;
    product=product*d;
}

// y为最终转换后的十进制数       

C++:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n,b;
    cin>>n>>b;
    int ans[30],i = 0 ;
    do{
        ans[i++] = n%b;
        n /= b;
    }while(n!=0);
    int flag = 1;
    for(int j = 0;j<=i/2;j++){
        if(ans[j]!=ans[i-j-1]) flag=0;
    }
    if(flag == 1) cout<<"Yes"<<endl;
    else cout<<"No"<<endl;
    for(int  j= i-1 ;j>=0 ;j--) {
         cout<<ans[j];
        if(j!=0) cout<<" ";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值