PAT 甲 1052 链表排序 Linked List Sorting

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10
​5
​​ ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next
where Address is the address of the node in memory, Key is an integer in [−10
​5
​​ ,10
​5
​​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.
Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题意:
链表由一系列的结构体组成,每个结构体中包含一个 Key 值和一个指向下一个结构体的 Next 指针。
按照 Key 值升序的顺序将链表重新排序。
题中可能包含不在链表中的节点,这些节点无需统计,无需排序,无需输出。
链表可能为空。(头节点地址为 −1)
思路:
结构体存储链表,然后对结构体以关键字data排序
排序范围在 node~node+MAXN,所以避免原始为0的结点排到前面,设置flag,重写cmp函数保证有效结点都在结构体数组前面
C++

#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+10;
struct node1{
    int data;
    int next;
    int add;
    int flag=0;
}temp[N],node[N];
bool cmp(node1 a,node1 b){
    if(a.flag == 0 || b.flag ==0)  return a.flag>b.flag;
    return a.data<b.data;
}   
int main(){
    int n,add;
    cin>>n>>add;
    int data,a1,a2;
    for(int i=0;i<n;i++){
        cin>>a1>>data>>a2;
        temp[a1].data = data;
        temp[a1].next = a2;
        temp[a1].add = a1;
    }
    int sum=0;
    for(int i = add ; i!=-1;i=temp[i].next){
        sum++;
        temp[i].flag = 1;
    }
    sort(temp,temp+N,cmp);
    if(sum==0) cout<<"0 -1";
    else{
    printf("%d %05d\n",sum,temp[0].add);
    for(int i =0 ; i<sum;i++){
        if(i!=sum-1){
            printf("%05d %d %05d\n",temp[i].add,temp[i].data,temp[i+1].add);
        }
        else printf("%05d %d -1\n",temp[i].add,temp[i].data,temp[i+1].add);
            
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值