hdoj 1518 Square (DFS + 剪枝)

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7461    Accepted Submission(s): 2412


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source

题目大意:给出一些小木棍的长度,问能够拼成一个正方形,即分成等长的四组
解题思路:深搜,但需要一些剪枝,首先按从大到小排序,按顺序搜索,在每一组的搜索过程中,如果有一根木条没有被用,就不会再被用到。这个剪枝可以剪到578MS,AC没有问题了,如果想进一步优化,还有一个剪枝就是如果搜索到一组没有能拼成的,就不用再继续往后搜索了,直接退出返回0。可优化到62MS。其他就是很显然的一些小剪枝了,比如和被4整除之类的。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 25;

int a[N];
int vis[N];
int n, k;
int tlen;

int dfs(int cur, int len, int dep){
    if(cur > 3) return 1;
    for(int i = dep + 1; i < n; i++){
        if(!vis[i]){
            vis[i] = 1;
            if(len + a[i] == k){
                if(dfs(cur + 1, 0, -1)) return 1;
            }
            else if(len + a[i] < k){
                if(dfs(cur, len + a[i], i)) return 1;
            }
            vis[i] = 0;
            if(len == 0) break;
        }
    }
    return 0;
}

int cmp(int x, int y){
    return x > y;
}

int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        memset(vis, 0, sizeof(vis));
        memset(a, 0, sizeof(a));
        scanf("%d", &n);
        int sum = 0;
        for(int i = 0; i < n; i++){
            scanf("%d", &a[i]);
            sum += a[i];
        }
        if(sum % 4 != 0){
            puts("no");
            continue;
        }
        k = sum / 4;
        sort(a, a + n, cmp);
        if(a[0] > k || n < 4){
            puts("no");
            continue;
        }
        if(dfs(0, 0, -1)) puts("yes");
        else puts("no");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值