hdoj - 2196 - Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2963    Accepted Submission(s): 1503


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 

求每个点到叶子节点的最大距离。
如果转化成一颗有根数,那么最长距离只可能来自于到子树叶节点或者父节点的最大距离加上该节点到父节点的距离。
先一遍dfs求出每个点到子节点的最大距离及次大距离,之所以求次大距离是因为如果父节点的最大距离路径恰好经过当前节点,那么父节点加的就是次短路径。再一遍DFS即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<map>
using namespace std;
const int N = 10010;

struct edge{
    int to, val;
}e;
vector<edge> G[N];
int vis[N];
int maxn[N];
int smaxn[N];
int maxid[N];
int smaxid[N];
int res[N];
int n;

void dfs1(int x){
    int len = G[x].size();
    for(int i = 0; i < len; i++){
        if(!vis[G[x][i].to]){
            vis[G[x][i].to] = 1;
            dfs1(G[x][i].to);
            int t1 = G[x][i].to;
            if(smaxn[x] < maxn[t1] + G[x][i].val){
                smaxn[x] = maxn[t1] + G[x][i].val;
                smaxid[x] = t1;
                if(smaxn[x] > maxn[x]){
                    swap(smaxn[x], maxn[x]);
                    swap(smaxid[x], maxid[x]);
                }
            }
        }
    }
}

void dfs2(int x){
    int len = G[x].size();
    for(int i = 0; i < len; i++){
        int g = G[x][i].to;
        if(!vis[g]){
            vis[g] = 1;
            if(g == maxid[x]) res[g] = max(res[x], smaxn[x]) + G[x][i].val;
            else res[g] = max(res[x], maxn[x]) + G[x][i].val;
            dfs2(g);
        }
    }
}

int main(){
    while(scanf("%d", &n) != EOF){
        for(int i = 0; i <= n; i++) G[i].clear();
        for(int i = 2; i <= n; i++){
            scanf("%d%d", &e.to, &e.val);
            G[i].push_back(e);
            int tmp = e.to;
            e.to = i;
            G[tmp].push_back(e);
        }
        memset(vis, 0, sizeof(vis));
        memset(maxn, 0, sizeof(maxn));
        memset(smaxn, 0, sizeof(smaxn));
        memset(maxid, 0, sizeof(maxid));
        memset(smaxid, 0, sizeof(smaxid));
        vis[1] = 1;
        dfs1(1);
        memset(res, 0, sizeof(res));
        memset(vis, 0, sizeof(vis));
        vis[1] = 1;
        dfs2(1);
        for(int i = 1; i <= n; i++)
            printf("%d\n", max(maxn[i], res[i]));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值