IE浏览器各版本与web标准不兼容问题解决方案

  做web开发的程序员,对浏览器的兼容性处理一直是个头疼的问题。昨天在处理一个页面的bug时也遇到了同类问题,在Internet搜索了一下最终找到比较满意的方案。在这个贴出来算是加深记忆吧!

     问题引出:一个页面在ie7和ie8上面运行良好,但是在ie6上面总是在加载时出现js错误(缺少对象之类)。

     解决方法:仔细检查了一下页面代码没有发现bug,无奈之下只有将找到的一段代码贴上去看看效果 。  

 <!--[if lt IE 7]>
 <script src="http://ie7-js.googlecode.com/svn/version/2.1(beta3)/IE7.js"></script>
 <![endif]-->

  运行了一下,bug居然不存在了功能也正常。这时才知道是浏览器和web标准不兼容问题引起的。

  http://code.google.com/p/ie7-js/  这个网站有对该js库的详细介绍以及demo,可以参阅一下。 

   另外,如果页面上面有一些样式,在ie7里面正常在其他的ie版本里面显示不正常,可以加上下面的一点内容:  

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

 一般来说,如上所述的兼容性问题都是可以处理的。

阅读更多
个人分类: javaWeb
上一篇Java Websites
下一篇Eclipse SVN插件的帐号、密码修改
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭