Ugly Numbers(1.5.8)

Ugly Numbers(1.5.8)

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10
题意:
把质因子只有2,3,5的数称为Ugly数,求第k大的Ugly数。(1是第一个)
思路:
定义优先队列,数越小优先级越高,先出队列,然后*2 *3 *5进队列(注意消去重复的数)
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
#define ll __int64
struct node  
{
	ll num;
	friend bool operator < (const node &a,const node &b)//定义优先级
	{
		return a.num>b.num;
	}
};
ll bfs(ll n) 
{
	ll sum;
	node x,y,z;
	sum=0;
	priority_queue<node>que;
		x.num=1;z.num=0; 
		que.push(x);// 1进队列
	while(1)
	{
		x=que.top();
		que.pop();//优先级最高的先出队列
		if(x.num==z.num) continue;//与之前重复的数不计
		sum++;
		if(sum==n) return x.num;//找到第n个
		y.num=x.num*2;
		que.push(y);
		y.num=x.num*3;
		que.push(y);
		y.num=x.num*5;
		que.push(y);
		z.num=x.num;
	}
	return 0;
}
int main()
{
	ll num;
	while(scanf("%I64d",&num)&&num)
	{
		printf("%I64d\n",bfs(num));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值