poj-1840 Eqs(hash)

Eqs
Time Limit:5000MS     Memory Limit:65536KB 
Description
Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 
Input
The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output
The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47
Sample Output

654

题意:输入5个数(a1,a2,a3,a4,a5)∈[-50,50],求满足a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 的多项式的个数(x1,x2,x3,x4,x5)∈[-50,50]。

    由于范围太大不能用暴力方法,可以转换成a1x13+ a2x23=-a3x33+ a4x43+ a5x53,先求出所有a1x13+ a2x23不同值的个数存入表中,(数组无法表示负值,可开范围最小50*50*50*50*3*2=37500000)。然后求s=-a3x33+ a4x43+ a5x53的所有值,如果之前该值出现过(即f[s]!=0) sum+=f[s];

#include<stdio.h>
#include<string.h>
#define size 18750000
short f[37500001];
//char f[37500001];
//short类型 56260K	297MS
//char类型 29868K	329MS
int main()
{
	int i,j,k,a1,a2,a3,a4,a5;
	int sum=0;
	scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5);
	memset(f,0,sizeof(0));
	for(i=-50;i<=50;i++)
	{
		if(i==0) continue;
		for(j=-50;j<=50;j++)
		{
			if(j==0) continue;
			f[a1*i*i*i+a2*j*j*j+size]++;
		}
	}
	for(i=-50;i<=50;i++)
	{
		if(i==0) continue;
		for(j=-50;j<=50;j++)
		{
			if(j==0) continue;
			for(k=-50;k<=50;k++)
			{
				if(k==0) continue;
				int s=-(a3*i*i*i+a4*j*j*j+a5*k*k*k)+size;
				if(f[s]) sum+=f[s];
			}
		}
	}
	printf("%d\n",sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值