HLG-1375(矩阵乘法+快速幂)

The Active Leyni
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 54(25 users)Total Accepted: 32(22 users)Rating:Special Judge: No
Description

There is a map of the town where Leynilives.

The vertex S indicates the home of Leyniand the vertexes A, B, C indicate the homes of his friends. They are connectedto each other as the map presents.

Leyni is too active that he can’t stayidle. It will count one step every time when he walks from one place toanother. He starts from his home S and won’t stop.

He wonders the number of ways in which hecan go from his home S to itself in exactly n steps. Thenumber may be quite large, you should output it modulo 1000000007.


Input

There are multiple test cases. Thefirst line of input is an integer T indicating the number of test cases. Then T test cases follow.

For each test case:

Line 1. This line contains an integer n (1 ≤ n ≤ 109) indicating the required steps.

Output

For each test case:

Line 1. Output the number of waysmodulo 1000000007.

Sample Input

2

2

4

Sample Output

3

21

Hint

In the first sample, the possible pathsare:

S=>A=>S

S=>B=>S

S=>C=>S

题意:从s出发,求走n步回到s的路径数。

设s[i][S]为走i步到S的路径数,则

由动态规划思想推得:

s[i][S]=s[i-1][A]+s[i-1][B]+s[i-1][C],即3*s[i-1][A];

s[i][A]=s[i-1][B]+s[i-1][C]+s[i-1][S],即2*s[i-1][A]+s[i-1][S];

同理B,C;

由此可通过矩阵乘的快速幂运算快速求得,

构造矩阵

0  3     X    0(S)   0

1  2            1(A)   0

#include<iostream>
using namespace std;
#define s 1000000007
void mul(long int a[2][2],long int b[2][2])
{
	long int c[2][2];
			for(int i=0;i<2;i++)
				for(int j=0;j<2;j++)
				{
					c[i][j]=0;
					for(int k=0;k<2;k++)
						c[i][j]=(c[i][j]+a[i][k]*b[k][j])%s;
				}
				for(int x=0;x<2;x++)
					for(int y=0;y<2;y++)
						b[x][y]=c[x][y];
}
void f(int x,long int a[2][2],long int b[2][2])
{
	while(x)
	{
		if(x&1)
			mul(a,b);
		mul(a,a);
		x>>=1;
	}
}
int main()
{
	int n;
	long int x;
	cin>>n;
	while(n--)
	{
		long int a[2][2]={0,3,1,2};
		long int b[2][2]={0,0,1,0};
		cin>>x;
		f(x-1,a,b);
		cout<<b[0][0]<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值