The Active Leyni | ||||||
| ||||||
Description | ||||||
There is a map of the town where Leynilives. The vertex S indicates the home of Leyniand the vertexes A, B, C indicate the homes of his friends. They are connectedto each other as the map presents. Leyni is too active that he can’t stayidle. It will count one step every time when he walks from one place toanother. He starts from his home S and won’t stop. He wonders the number of ways in which hecan go from his home S to itself in exactly n steps. Thenumber may be quite large, you should output it modulo 1000000007. | ||||||
Input | ||||||
There are multiple test cases. Thefirst line of input is an integer T indicating the number of test cases. Then T test cases follow. For each test case: Line 1. This line contains an integer n (1 ≤ n ≤ 109) indicating the required steps. | ||||||
Output | ||||||
For each test case: Line 1. Output the number of waysmodulo 1000000007. | ||||||
Sample Input | ||||||
2 2 4 | ||||||
Sample Output | ||||||
3 21 | ||||||
Hint | ||||||
In the first sample, the possible pathsare: S=>A=>S S=>B=>S S=>C=>S |
设s[i][S]为走i步到S的路径数,则
由动态规划思想推得:
s[i][S]=s[i-1][A]+s[i-1][B]+s[i-1][C],即3*s[i-1][A];
s[i][A]=s[i-1][B]+s[i-1][C]+s[i-1][S],即2*s[i-1][A]+s[i-1][S];
同理B,C;
由此可通过矩阵乘的快速幂运算快速求得,
构造矩阵
0 3 X 0(S) 0
1 2 1(A) 0
#include<iostream>
using namespace std;
#define s 1000000007
void mul(long int a[2][2],long int b[2][2])
{
long int c[2][2];
for(int i=0;i<2;i++)
for(int j=0;j<2;j++)
{
c[i][j]=0;
for(int k=0;k<2;k++)
c[i][j]=(c[i][j]+a[i][k]*b[k][j])%s;
}
for(int x=0;x<2;x++)
for(int y=0;y<2;y++)
b[x][y]=c[x][y];
}
void f(int x,long int a[2][2],long int b[2][2])
{
while(x)
{
if(x&1)
mul(a,b);
mul(a,a);
x>>=1;
}
}
int main()
{
int n;
long int x;
cin>>n;
while(n--)
{
long int a[2][2]={0,3,1,2};
long int b[2][2]={0,0,1,0};
cin>>x;
f(x-1,a,b);
cout<<b[0][0]<<endl;
}
return 0;
}