HLG-1375(矩阵乘法+快速幂)

本文介绍了一个算法问题,即计算从起点出发,在限定步数内返回起点的所有可能路径数量。通过构建矩阵并运用快速幂运算的方法,高效地解决了该问题。
摘要由CSDN通过智能技术生成

The Active Leyni
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 54(25 users)Total Accepted: 32(22 users)Rating:Special Judge: No
Description

There is a map of the town where Leynilives.

The vertex S indicates the home of Leyniand the vertexes A, B, C indicate the homes of his friends. They are connectedto each other as the map presents.

Leyni is too active that he can’t stayidle. It will count one step every time when he walks from one place toanother. He starts from his home S and won’t stop.

He wonders the number of ways in which hecan go from his home S to itself in exactly n steps. Thenumber may be quite large, you should output it modulo 1000000007.


Input

There are multiple test cases. Thefirst line of input is an integer T indicating the number of test cases. Then T test cases follow.

For each test case:

Line 1. This line contains an integer n (1 ≤ n ≤ 109) indicating the required steps.

Output

For each test case:

Line 1. Output the number of waysmodulo 1000000007.

Sample Input

2

2

4

Sample Output

3

21

Hint

In the first sample, the possible pathsare:

S=>A=>S

S=>B=>S

S=>C=>S

题意:从s出发,求走n步回到s的路径数。

设s[i][S]为走i步到S的路径数,则

由动态规划思想推得:

s[i][S]=s[i-1][A]+s[i-1][B]+s[i-1][C],即3*s[i-1][A];

s[i][A]=s[i-1][B]+s[i-1][C]+s[i-1][S],即2*s[i-1][A]+s[i-1][S];

同理B,C;

由此可通过矩阵乘的快速幂运算快速求得,

构造矩阵

0  3     X    0(S)   0

1  2            1(A)   0

#include<iostream>
using namespace std;
#define s 1000000007
void mul(long int a[2][2],long int b[2][2])
{
	long int c[2][2];
			for(int i=0;i<2;i++)
				for(int j=0;j<2;j++)
				{
					c[i][j]=0;
					for(int k=0;k<2;k++)
						c[i][j]=(c[i][j]+a[i][k]*b[k][j])%s;
				}
				for(int x=0;x<2;x++)
					for(int y=0;y<2;y++)
						b[x][y]=c[x][y];
}
void f(int x,long int a[2][2],long int b[2][2])
{
	while(x)
	{
		if(x&1)
			mul(a,b);
		mul(a,a);
		x>>=1;
	}
}
int main()
{
	int n;
	long int x;
	cin>>n;
	while(n--)
	{
		long int a[2][2]={0,3,1,2};
		long int b[2][2]={0,0,1,0};
		cin>>x;
		f(x-1,a,b);
		cout<<b[0][0]<<endl;
	}
	return 0;
}


内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值