NYOJ 题目401 Coin Game

Coin Game

时间限制: 1000 ms  |  内存限制: 32768 KB
难度: 2
描述
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 
Your job is to find out who will definitely win the game.
输入
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10^9,1<=K<=10).
输出
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
样例输入
2
3 1
3 2
样例输出
Case 1: first
Case 2: second
 
   
博弈论,先下手就输。
 
   
#include <stdio.h>
int main(void)
{
    //freopen("题目401.txt","r",stdin);
    int n,i,m,k;
    while(scanf("%d",&n)!=EOF)
    {

        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&m,&k);

                if((k==1&&m%2)||m<=k) printf("Case %d: first\n",i);
            else printf("Case %d: second\n",i);

        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值