POJ 1208 The Blocks Problem

23 篇文章 0 订阅
16 篇文章 0 订阅
The Blocks Problem
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4914 Accepted: 2090
Description

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will "program" a robotic arm to respond to a limited set of commands.
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0 <= i < n-1 as shown in the diagram below:


The valid commands for the robot arm that manipulates blocks are:

move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.


move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.


pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.


pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.


quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.
Output

The output should consist of the final state of the blocks world. Each original block position numbered i ( 0 <= i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).
Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit
Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:

9:


机器人按照指示将木块移动,这题用到的是向量,二维的,


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <stdio.h>
#include <fstream>
using namespace std;
vector<int> p[30];
int n;
void find_pi(int a,int &pa,int &ha)
{
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<p[i].size();j++)
        {
            if(a==p[i][j])
            {
                pa=i;
                ha=j;
                return ;
            }
        }
    }
}

void moven(int pa,int ha,int pb)
{
    for(int i=ha;i<p[pa].size();i++)
    {
        p[pb].push_back(p[pa][i]);
    }
    p[pa].resize(ha);
}

void guiwei(int pa,int ha)
{
    for(int i=ha+1;i<p[pa].size();i++)
    {
        p[p[pa][i]].push_back(p[pa][i]);
    }
    p[pa].resize(ha+1);
}

int main(void)
{
    //freopen("B.txt","r",stdin);
  // ifstream cin("B.txt");
   // int n;
    string s1,s2;
    int a,b;
      cin>>n;
    for(int i=0;i<n;i++)
        p[i].push_back(i);
   while(1)
    {
       cin>>s1>>a>>s2>>b;
      //  cout<<s1<<" "<<a<<" "<<s2<<" "<<b<<endl;
        if(s1=="quit") break;
        int pa,pb,ha,hb;
        find_pi(a,pa,ha);
        find_pi(b,pb,hb);
     //   cout<<"a ="<<a<<" "<<pa<<" "<<ha<<endl;
     //   cout<<"b ="<<b<<" "<<pb<<" "<<hb<<endl;
        if(pa==pb) continue;
        /*
        if(s1=="move")
        {
            if(s2=="onto")
            {
                guiwei(pa,ha);
                guiwei(pb,hb);
                p[pb].push_back(pa);
                p[pa].resize(p[pa].size()-1);
            }
            else if(s2=="over")
            {
                guiwei(pa,ha);
                p[pb].push_back(pa);
                p[pa].resize(p[pa].size()-1);
            }
        }
        else if(s1=="pile")
        {
            if(s2=="onto")
            {
                guiwei(pb,hb);
                moven(pa,ha,pb);
            }
            else if(s2=="over")
            {
                moven(pa,ha,pb);
            }
        }
        */
        if(s2=="onto") guiwei(pb,hb);
        if(s1=="move") guiwei(pa,ha);
        moven(pa,ha,pb);
    }
    for(int i=0;i<n;i++)
    {
        printf("%d:",i);
       // vector<int>::iterator it;
       //   for( it = p[i].begin(); it != p[i].end(); it++ )
         //  cout << " "<<*it ;
               // cout<<endl;
               for(int j=0;j<p[i].size();j++)
               {
                   printf(" %d",p[i][j]);
               }
               printf("\n");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值