POJ 3268 Silver Cow Party

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14787 Accepted: 6687

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


套模板就好啦。。。都说frod算法会超时,我用了倒没超时。。

我先算的从聚会的点回到自己家,这个很好算,bellman_ ford就是算这个的,这个点到所有点的最短路径就保存在d[]数组里,

然后再算每一点到聚会那点的最短路径,也就是利用v-1次bellman_ford函数,每次调用完函数,就记这个点到聚会那个点的最短路径就行,

最后,把每一点到聚会那点的距离加上聚会那点到这一点的距离,就是牛牛从家到聚会在回家的最短路径啦,

最后的最后,把每一头牛牛的最短路径都算好,从中找出一条最长的路,就是答案。


#include <iostream>
#include <cstring>
#include <cstdio>
#define inf 1e7
using namespace std;
struct edge
{
    int from;//从顶点from指向顶点to的权值为cost的彼边
    int to;
    int cost;//权重
}es[50005];//边
int d[50005];
int v,e;
//求解从顶点s出发到所有点的最短距离

void shortest_path(int s)
{
    for(int i=0;i<v;i++)
        d[i]=inf;
    d[s]=0;
    while(true)
    {
        bool update=false;
        for(int i=0;i<e;i++)
        {
            struct edge ee;
            ee=es[i];
            if((d[ee.from]!=inf)&&(d[ee.to]>(d[ee.from]+ee.cost)))
            {
                d[ee.to]=d[ee.from]+ee.cost;
                update=true;
            }
        }
        if(!update) break;
    }
}
int main(void)
{
   // freopen("B.txt","r",stdin);
    int n;

    cin>>v>>e>>n;

    for(int i=0;i<e;i++)
    {
        int a,b,c;
        cin>>a>>b>>c;
        es[i].from=a-1;
        es[i].to=b-1;
        es[i].cost=c;
    }
   // cout<<n-1<<endl;

    shortest_path(n-1);
    int a[1005];
    for(int i=0;i<v;i++)
        a[i]=d[i];
    for(int i=0;i<v;i++)
    {
        shortest_path(i);
        a[i]+=d[n-1];
    }
    int max=-1;
    for(int i=0;i<v;i++)
    {
        max=(max>a[i])?max:a[i];
    }
    cout<<max<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值