PKU1860 Currency Exchange bellman求最长路

Currency Exchange

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 37   Accepted Submission(s) : 18
Problem Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
 

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4
 

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
 

Sample Input
  
  
3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00
 

Sample Output
  
  
YES
 

Source
PKU
 


题意:描述一个exchange point的六个数分别为交换的两种货币a,b a对b的汇率c,a对b时的commission d,b对a的汇率e,b对a的commission f.有m条转换方式,但是是双向可以转换的所以共有m*2条路,数组dist[]保存的是从某一点可以有的最大金额(将初始货币转换为当前货币时当前货币的最大值),s为起点,所以dist[s]=v,bellman是用来求最短路,并判断有无负环的,但是在这个题目中,一定会有环,我们要做的是看从s出发绕过一圈后回到s后,dist[s]的有没有增加,如果增加了就输出YES,一旦增加则不存在最长路,钱就会越来越多,而bellman最后是在判断一旦出现负环则一定不存在最短路,发现了吗,这是一个在求最长路一个在求最短路,所以可以将bellman改造一下,就可以求最长路的,改造方法是将dist[]初始化为0(求最长路啊,优先取最大的,如果初始化为INF,可以想到如果取大的会是什么结果,求最短路初始化INF,最长路初始0或负数,才能表示一开始的边都不存在,然后才能一步步优化)。


AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
#define N 105
bool bell ();

using namespace std;

int n,m,s;
double v;
double dist[N];

struct money
{
    int from,to;
    double r,c;
}mp[256];

int main()
{
    int i,j;
    int a,b;
    double c,d,e,f,sum;

    while(~scanf("%d%d%d%lf",&n,&m,&s,&v))
    {

        for(i=1;i<=2*m;i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f);
            mp[i].from=a;
            mp[i].to=b;
            mp[i].r=c;
            mp[i++].c=d;
            mp[i].from=b;
            mp[i].to=a;
            mp[i].r=e;
            mp[i].c=f;
        }

        if(bell())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

bool bell ()
{
    int i,j,k;

    memset(dist,0,sizeof(dist));

    dist[s]=v;

    for(i=1;i<n;i++)
    {
        for(j=1;j<=2*m;j++)
            if(dist[mp[j].to]<(dist[mp[j].from]-mp[j].c)*mp[j].r)
        dist[mp[j].to]=(dist[mp[j].from]-mp[j].c)*mp[j].r;
    }

    for(j=1;j<=2*m;j++)
       if(dist[mp[j].to]<(dist[mp[j].from]-mp[j].c)*mp[j].r)
    {
        return true;
    }

    return false;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值