矩阵求和--重载运算符

/*

Problem E: C++习题 矩阵求和--重载运算符

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 592  Solved: 205
[
Submit ][ Status ][ Web Board ]

Description

有两个矩阵a和b,均为2行3列。求两个矩阵之和。重载运算符“+”,使之能用于矩阵相加(如c=a+b)。
重载流插入运算符“<<”和流提取运算符“>>”,使之能用于该矩阵的输入和输出。

Input

两个2行3列矩阵

Output

矩阵之和

Sample Input

1 2 3
4 5 6

7 8 9
1 2 3

Sample Output

8 10 12
5 7 9

HINT

前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部



/* C++代码 */

#include <iostream>

using namespace std;

class Matrix

{

public:

    Matrix();

    friend Matrix operator+(Matrix &,Matrix &);

    friend ostream& operator<<(ostream&,Matrix&);

    friend istream& operator>>(istream&,Matrix&);

private:

    int mat[2][3];

};





主函数已给定如下,提交时不需要包含,会自动添加到程序尾部



/* C++代码 */



int main()

{

    Matrix a,b,c;

    cin>>a;

    cin>>b;

    c=a+b;

    cout<<c<<endl;

    return 0;

}

*/

#include <iostream>

using namespace std;

class Matrix

{

public:

    Matrix();

    friend Matrix operator+(Matrix &,Matrix &);

    friend ostream& operator<<(ostream&,Matrix&);

    friend istream& operator>>(istream&,Matrix&);

private:

    int mat[2][3];

};

Matrix::Matrix(){};

Matrix operator + (Matrix &a,Matrix &b)
{
    int i,j;
    Matrix c;
    for(i=0;i<2;i++)
        for(j=0;j<3;j++)
            c.mat[i][j] = a.mat[i][j] + b.mat[i][j];
    return c;
}
ostream& operator << (ostream & output,Matrix &a)
{
    for(int i=0;i<2;i++)
        for(int j=0;j<3;j++)
        {
            output<<a.mat[i][j];
            if(j!=2)
                output<<' ';
            else if(i!=1)
                output<<endl;
        }
    return output;
}
istream& operator >>(istream & input,Matrix &a)
{
    for(int i=0;i<2;i++)
        for(int j=0;j<3;j++)
            input>>a.mat[i][j];
    return input;
}
int main()

{

    Matrix a,b,c;

    cin>>a;

    cin>>b;

    c=a+b;

    cout<<c<<endl;

    return 0;

}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

IT研究僧大师兄

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值