F - Ride to School(2.1.2)

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0

Sample Output

780
771

分析:要想用时最短,charly必须跟随速度最快且出发时间为大于0的人,他的总时间即为速度最快的人所用时间加上其出发时间。因为charly在0秒以后出发,
不管什么时候出发,这个时间总是包含在速度最快的那个人的出发时间里。
下面是AC的代码:


#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n , mintime , v , t ;
    while( cin >> n && n != 0 )
    {
        mintime = 10e5 ;
        while( n-- )
        {
            cin >> v >> t;
            if( ceil( t + 4.5 * 3600 / double(v) ) < mintime && t >= 0) //找出用时最短的人
            {
                mintime = ceil( t + 4.5 * 3600 / double(v) ) ;   //赋给charly
            }
        }
        cout << mintime << endl ;

    }
    return 0;
}

开始我的方法并不是上面的,而是使用了数组,但不知为何,老是runtime error!

然后我去掉数组,通过找出最大速度者的方式来做,却是Wrong Answer!!仍然不知其原因。在此记录下。如果大家能看到,找出其中的 错误的话,在下面留言,感激不尽!

代码如下:


#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n , ttime , vm , k , v , t ;
    while( cin >> n && n != 0 )
    {
        vm = 10e-5 ;
        k = 10e5;
        while( n-- )
        {
            cin >> v >> t;
            if( vm <= v && t >= 0)
            {
                vm = v ;
                k = t ;
            }
        }
        ttime = ceil( k + 4.5 * 3600 / double(vm) ) ;
        cout << ttime << endl ;

    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

IT研究僧大师兄

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值