【POJ】2185 Milking Grid(KMP)

Milking Grid

Description

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

Input

* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 

Output

* Line 1: The area of the smallest unit from which the grid is formed 

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern 'AB'.

1、最小子矩阵复制后要覆盖原矩阵,也就是说子矩阵必须包含原来矩阵的所有字母,因此我们只需要求的每一行,每一列的最小重复子串即可,这个求解利用到了kmp算法中next数组的一个性质。
2、再求出各行列的最小重复子串后,只需对所有行的答案求其最小公倍数和所有列的答案求其最小公倍数就可以得到最终答案了。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <string>
using namespace std;
char str[10010][100];
int R,C;
bool same1(int i,int j)//第i行和第j行相等
{
    for(int k=0;k<C;k++)
        if(str[i][k]!=str[j][k])
            return false;
    return true;
}
bool same2(int i,int j)//第i列和第j列相等
{
    for(int k=0;k<R;k++)
        if(str[k][i]!=str[k][j])
            return false;
    return true;
}
const int MAXN=10010;
int next[MAXN];
int main()
{
    while(scanf("%d%d",&R,&C)==2)
    {
        for(int i=0;i<R;i++)scanf("%s",str[i]);
        int i,j;
        j=next[0]=-1;
        i=0;
        while(i<R)
        {
            while(-1!=j && !same1(i,j))j=next[j];
            next[++i]=++j;
        }
        int ans1=R-next[R];
        j=next[0]=-1;
        i=0;
        while(i<C)
        {
            while(-1!=j && !same2(i,j))j=next[j];
            next[++i]=++j;
        }
        int ans2=C-next[C];
        printf("%d\n",ans1*ans2);
    }
    return 0;
}

—————————————————————————————————

本文原创自Sliencecsdn技术博客。

本博客所有原创文章请以链接形式注明出处。

欢迎关注本技术博客,本博客的文章会不定期更新。


大多数人想要改造这个世界,但却罕有人想改造自己。

世上没有绝望的处境,只有对处境绝望的人。

                                              ————By slience

—————————————————————————————————



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值