【HDU】 4763 Theme Section (KMP)

Theme Section

Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

 

Sample Input
5 xy abc aaa aaaaba aaxoaaaaa
 

 

Sample Output
0 0 1 1 2

1、先求出S串的next数组。
2、然后从next[n]开始,如果next[n]<=n/3,然后从n/3+1开始到n-next[n]用kmp,判断是否存在1~next[n]的子串。如果不存在则继续往前找。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;

void kmp_pre(char x[],int m,int next[])
{
    int i,j;
    j = next[0] = -1;
    i = 0;
    while(i < m)
    {
        while( -1 != j && x[i] != x[j] )j = next[j];
        next[++i] = ++j;
    }
}
char str[1000010];
int next[1000010];
bool f[1000010];
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",str);
        int n = strlen(str);
        kmp_pre(str,n,next);
        memset(f,false,sizeof(f));
        int tmp = n;
        while(tmp > 0)
        {
            if(n >= 2*tmp)f[tmp] = true;
            tmp = next[tmp];
        }
        int ans = 0;
        for(int i = n-1;i > 1;i--)
        {
            tmp = i;
            while(tmp > 0)
            {
                if(f[tmp] && i >= 2*tmp && n >= i+tmp)
                {
                    ans = max(ans,tmp);
                    break;
                }
                tmp = next[tmp];
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

—————————————————————————————————

本文原创自Sliencecsdn技术博客。

本博客所有原创文章请以链接形式注明出处。

欢迎关注本技术博客,本博客的文章会不定期更新。


大多数人想要改造这个世界,但却罕有人想改造自己。

世上没有绝望的处境,只有对处境绝望的人。

                                              ————By slience

—————————————————————————————————


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值