hdu2143 box

box

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7186    Accepted Submission(s): 1452


Problem Description
One day, winnie received a box and a letter. In the letter, there are three integers and five operations(+,-,*,/,%). If one of the three integers can be calculated by the other two integers using any operations only once.. He can open that mysterious box. Or that box will never be open.
 

Input
The input contains several test cases.Each test case consists of three non-negative integers.
 

Output
If winnie can open that box.print "oh,lucky!".else print "what a pity!"
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
oh,lucky!
 
题意:有3个数字abc,五种操作(+-*/%),如果有一个数字能被另外两个数字用那5种操作之一一次计算出来,则输出oh,lucky!,否则输出what a pity!
加减互逆,乘除互逆,二者有一即可,这道题用除法会出问题,除法不是整除.也不能直接用加法。

#include<stdio.h>
#include <iostream>
using namespace std;
int main()
{
    long long a,b,c;
    while (scanf("%I64d%I64d%I64d",&a,&b,&c)!=EOF)
    {
        if(a*b==c|| a*c==b|| b*c==a)
        {
            printf("oh,lucky!\n");
        }
        else if((b!=0&& (a%b==c||c%b==a))||(a!=0&&(c%a==b||b%a==c))||(c!=0&&(a%c==b ||b%c==a)))
        {
           printf("oh,lucky!\n");
        }
        else
        {
            printf("what a pity!\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值