poj 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52467 Accepted: 11796

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题意为,在一个坐标系中,x中代表海岸,x轴以上有n个点,代表着n个岛屿,在x轴上建雷达,一直雷达的覆盖范围为半径为d的圆,求在x轴上最少建多少个雷达,才能把全部的岛屿覆盖起来,如果不能覆盖,输出-1.

贪心。这题就是在一条直线上画最少的覆盖直线一侧所有点的一系列圆。首先对每个点求出能覆盖到这个点的在直线上左右两极限位置的坐标。然后按照左极限位置对这些点排序。然后从左到右找到每个雷达最多能覆盖的岛屿数。(相当于处理区间覆盖问题)最后就得到了所需的雷达数。当有岛屿离海岸的距离大于雷达覆盖半径,则输出不可能。

(1)

#include <iostream>
#include <algorithm>
#include <math.h>
using namespace std;
struct node
{
    double left;
    double right;
};
int cmp(const node &a,const node &b)
{
    return a.left<b.left;
}
int main()
{
    int n,d,count=0;
    node a[1001];
    int flag;
    while (cin>>n>>d && (n||d))
    {
        flag=0;
        int x,y,ans=1;
        for (int i=0; i<n; i++)
        {
            cin>>x>>y;
            if(y>d)
            {
                flag=1;
            }
            a[i].left=x-sqrt(d*d-y*y);
            a[i].right=x+sqrt(d*d-y*y);
        }
        if(flag)
        {
            cout<<"Case "<<++count<<": "<<"-1"<<endl;
            continue;
        }
        sort(a, a+n, cmp);
        double Min=a[0].right;
        for (int i=1; i<n; i++)
        {
            if(a[i].left> Min)
            {
                ans++;
                Min=a[i].right;
            }
            else
            {
                   Min=Min>a[i].right?a[i].right:Min;
            }
        }
        cout<<"Case "<<++count<<": "<<ans<<endl;
        
    }
    return 0;
    
}

(2)按照右端点来排序

#include <iostream>
#include <algorithm>
#include <math.h>
using namespace std;
struct node
{
    double left;
    double right;
};
int cmp(const node &a,const node &b)
{
    return a.right<b.right;   //这里变了哟
}
int main()
{
    int n,d,count=0;
    node a[1001];
    int flag;
    while (cin>>n>>d && (n||d))
    {
        flag=0;
        int x,y,ans=1;
        for (int i=0; i<n; i++)
        {
            cin>>x>>y;
            if(y>d)
            {
                flag=1;
            }
            a[i].left=x-sqrt(d*d-y*y);
            a[i].right=x+sqrt(d*d-y*y);
        }
        if(flag)
        {
            cout<<"Case "<<++count<<": "<<"-1"<<endl;
            continue;
        }
        sort(a, a+n, cmp);
        double Min=-1000000;
        for (int i=0; i<n; i++)
        {
            if(a[i].left> Min)
            {
                ans++;
                Min=a[i].right;
            }
        }
        cout<<"Case "<<++count<<": "<<ans<<endl;
        
    }
    return 0;
    
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值