BNU 16485 Build The Electric System

Build The Electric System

Time Limit: 2000ms
Memory Limit: 65536KB
This problem will be judged on  ZJU. Original ID:  2966
64-bit integer IO format:  %lld      Java class name:  Main
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and lots of villages lost contact with the main power grid. The government wants to reconstruct the electric system as soon as possible. So, as a professional programmer, you are asked to write a program to calculate the minimum cost to reconstruct the power lines to make sure there's at least one way between every two villages.

    Input

    Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

    In each test case, the first line contains two positive integers N and E (2 <= N <= 500, N <= E <= N * (N - 1) / 2), representing the number of the villages and the number of the original power lines between villages. There follow E lines, and each of them contains three integers, ABK (0 <= AB < N, 0 <= K < 1000). A and B respectively means the index of the starting village and ending village of the power line. If K is 0, it means this line still works fine after the snow storm. If K is a positive integer, it means this line will cost K to reconstruct. There will be at most one line between any two villages, and there will not be any line from one village to itself.

    Output

    For each test case in the input, there's only one line that contains the minimum cost to recover the electric system to make sure that there's at least one way between every two villages.

    Sample Input

    1
    3 3
    0 1 5
    0 2 0
    1 2 9
    

    Sample Output

    5
    

    有n个城市,有m条线路,每条线路a,b,c表示a到b的线路需要花费c的费用维修,要求能将所有城市联通的最小维修花费。
    思路:按照花费从小到大将路线排序,然后再来一次并查集整合所有线路。

    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int Max=1010;
    int father[Max];
    int Find(int x)
    {
        while (x!=father[x])
        {
            x=father[x];
        }
        return x;
    }
    struct node
    {
        int a;
        int b;
        int c;
    }num[40010];
    int cmp(node a,node b)
    {
        return a.c<b.c;
    }
    int main()
    {
        int t,a,b;
        int ans;
        cin>>t;
        while (t--)
        {
            ans=0;
            cin>>a>>b;
            for (int i=0; i<a; i++)
            {
                father[i]=i;
            }
            for (int i=0; i<b; i++)
            {
                cin>>num[i].a>>num[i].b>>num[i].c;
            }
            
            sort(num, num+b, cmp);
            for (int i=0; i<b; i++)
            {
                int fx=Find(num[i].a);
                int fy=Find(num[i].b);
                if(fx!=fy)
                {
                    father[fx]=fy;
                    ans+=num[i].c;
                }
            }
            cout<<ans<<endl;
        }
        return 0;
    }



    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值