hdu 5012 Dice

Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 154    Accepted Submission(s): 89


Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A. 

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
  
  
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
  
  
0 3 -1
 

题意:给你两个筛子的序列(上下左右),通过左右上下的旋转方式使得两个筛子完全一样,求最小的步数,如不能达到输出-1.

广搜,对每个状态的筛子,进行上下左右的搜索,并标记。

#include <iostream>
#include <cmath>
#include <queue>
#include <stdio.h>
using namespace std;
int minstep;
char a[8]="\0";
struct node
{
    int Count;
    char b[8];
};
bool visit[654322];
void BFS(node num)
{
    queue<node>Q;
    Q.push(num);
    int x=atoi(num.b);
    visit[x]=1;
    while (!Q.empty())
    {
        node h=Q.front();
        Q.pop();
        if(strcmp(h.b,a)==0)
        {
            if(minstep>h.Count)
            {
                minstep=h.Count;
            }
        }
        else
        {
            //上
            char temp[8]="\0";
            temp[0]=h.b[4];
            temp[1]=h.b[5];
            temp[2]=h.b[2];
            temp[3]=h.b[3];
            temp[4]=h.b[1];
            temp[5]=h.b[0];
            int x=atoi(temp);
            if(!visit[x])
            {
                visit[x]=1;
                node hd=h;
                strcpy(hd.b, temp);
                hd.Count++;
                Q.push(hd);
                
            }
            //下
            temp[0]=h.b[5];
            temp[1]=h.b[4];
            temp[2]=h.b[2];
            temp[3]=h.b[3];
            temp[4]=h.b[0];
            temp[5]=h.b[1];
            x=atoi(temp);
            if(!visit[x])
            {
                visit[x]=1;
                node hd=h;
                strcpy(hd.b, temp);
                hd.Count++;
                Q.push(hd);
            }
            
            //左
            temp[0]=h.b[3];
            temp[1]=h.b[2];
            temp[2]=h.b[0];
            temp[3]=h.b[1];
            temp[4]=h.b[4];
            temp[5]=h.b[5];
            x=atoi(temp);
            if(!visit[x])
            {
                visit[x]=1;
                node hd=h;
                strcpy(hd.b, temp);
                hd.Count++;
                Q.push(hd);
            }
            
            //右
            temp[0]=h.b[2];
            temp[1]=h.b[3];
            temp[2]=h.b[1];
            temp[3]=h.b[0];
            temp[4]=h.b[4];
            temp[5]=h.b[5];
            x=atoi(temp);
            if(!visit[x])
            {
                visit[x]=1;
                node hd=h;
                strcpy(hd.b, temp);
                hd.Count++;
                Q.push(hd);
            }
        }
    }
}
int main()
{
    while (cin>>a[0])
    {
        node num;
        minstep=100000;
        memset(visit, 0, sizeof(visit));
        for (int i=1; i<=5; i++)
        {
            cin>>a[i];
        }
        num.b[6]='\0';
        for (int i=0; i<=5; i++)
        {
            cin>>num.b[i];
        }
        
        num.Count=0;
        
        BFS(num);
       if(minstep==100000)
       {
           cout<<"-1"<<endl;
       }
       else
       {
           cout<<minstep<<endl;
       }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值