zoj 2750 Idiomatic Phrases Game(最短路径)

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

题目大意:

给出n个字典,接下来n行第一个是查看字典的时间,后面接的是这个成语,要求把每条成语连起来,以成语接龙的形式。字符串代表成语,如果第一个串的后4个字符与第二个串的前4个字符相等,那么说明它们能连起来,用的时间是第一个成语的时间,每组数据输入的第一个成语和最后一个成语为已知的。输出最少的时间,不能完成则输出-1.


最短路

#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <string.h>
#include <iostream>
using namespace std;
const int Max=100000000;
int map[1000][1000];
int n;
struct node
{
    char front[5];
    char back[5];
    int w;
};
void Dijkstra(int v0)
{
    int lowcost[1005];
    bool  visit[1005];
    for (int i=0; i<n; i++)
    {
        visit[i]=false;
        lowcost[i]=map[v0][i];
    }
    visit[v0]=true;
    for (int i=0; i<n-1; i++)
    {
        int min=Max;
        int k=-1;
        for (int j=0; j<n; j++)
        {
            if(!visit[j] && min>lowcost[j])
            {
                min=lowcost[j];
                k=j;
            }
        }
        visit[k]=true;
        for (int j=0; j<n; j++)
        {
            if(!visit[j] && map[k][j] !=Max && map[k][j]+min<lowcost[j])
            {
                lowcost[j]=map[k][j]+min;
            }
        }
    }
    if(lowcost[n-1]==Max)
    {
        cout<<"-1"<<endl;
    }
    else
    {
        cout<<lowcost[n-1]<<endl;
        
    }
}
int main()
{
    node num[1005];
    while (cin>>n && n)
    {
        char str[100];
        for (int i=0; i<n; i++)
        {
            cin>>num[i].w>>str;
            long len=strlen(str);
            long j,k;
            for (j=len-1,k=0;k<4;k++,j--)
            {
                num[i].front[k]=str[k];
                num[i].back[3-k]=str[j];
            }
            num[i].front[4]='\0';
            num[i].back[4]='\0';
        }
        for (int i=0; i<n; i++)
        {
            for (int j=0; j<n; j++)
            {
                map[i][j]=Max;
                if(i==j)
                {
                    continue;
                }
                if(strcmp(num[i].back,num[j].front)==0)
                {
                    map[i][j]=num[i].w;
                }
            }
        }
        Dijkstra(0);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值