hdu 4771 Stealing Harry Potter's Precious(最短路径)

Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

Sample Input
  
  
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
  
  
-1 5

题目大意:在一个N*M的银行里,贼的位置在’@‘,现在给出n个宝物的位置,现在贼要将所有的宝物拿到手,问最短的路径,不需要考虑离开。

思路:bfs求出两两之间的权值进行建图,然后通过dfs求答案,宝物最多才4个,所以暴力是没问题的。

#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
int n,m,k;
struct node
{
    int x,y;
    int step;
    bool operator<(const node &t)const
    {
        return t.step<step;
    }
}num[5];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
char map[105][105];
bool Vis[10];
int dist[10][10];
bool judge(node &a,bool vis[][105])
{
    if(a.x>=0 && a.x<n && a.y>=0 && a.y<m && !vis[a.x][a.y] && map[a.x][a.y]=='.')
    {
        return true;
    }
    return false;
}

int bfs(node s,node e)
{
    bool vis[105][105];
    memset(vis, false, sizeof(vis));
    priority_queue<node>q;
    q.push(s);
    vis[s.x][s.y]=true;
    while (!q.empty())
    {
        node h=q.top();
        node temp;
        q.pop();
        if(h.x==e.x && h.y==e.y)
        {
            return h.step;
        }
        for (int i=0; i<4; i++)
        {
            temp.x=h.x+dir[i][0];
            temp.y=h.y+dir[i][1];
            temp.step=h.step+1;
            if(judge(temp,vis))
            {
                vis[temp.x][temp.y]=true;
                q.push(temp);
            }
        }
    }
    
    return -1;
}
int dfs(int u,int cnt)
{
    if(cnt==k)
    {
        return 0;
    }
    int ans=1000000;
    for (int v=1; v<=k; v++)
    {
        if(dist[u][v]==-1 || Vis[v])
        {
            continue;
        }
        Vis[v]=true;
        ans=min(ans,dfs(v, cnt+1)+dist[u][v]);
        Vis[v]=false;
    }
    return ans;
}
int main()
{
    while (scanf("%d%d",&n,&m) && (n||m))
    {
        for (int i=0; i<n; i++)
        {
            scanf("%s",map[i]);
            for (int j=0; j<m; j++)
            {
                if(map[i][j]=='@')
                {
                    num[0].x=i;
                    num[0].y=j;
                    num[0].step=0;
                    break;
                }
            }
        }
        scanf("%d",&k);
        for (int i=1; i<=k; i++)
        {
            scanf("%d%d",&num[i].x,&num[i].y);
            num[i].x--;
            num[i].y--;
            num[i].step=0;
            
        }
        memset(dist, -1, sizeof(dist));
        bool flag=false;
        // bfs 求权值 并建图
        for (int i=1; i<=k; i++)
        {
            dist[0][i]=bfs(num[0], num[i]);
            if(flag)
            {
                flag=true;
                break;
            }
            for (int j=i+1; j<=k; j++)
            {
                dist[i][j]=dist[j][i]=bfs(num[i], num[j]);
                // 除出发点外 如果存在两个点无法到达则无法求出
                if(dist[i][j]==-1)
                {
                    flag=true;
                    break;
                }
            }
        }
        
        //如果出发点与所有坐标都不通也是不行的
        for (int i=1; i<=k; i++)
        {
            if(dist[0][i]!=-1 || flag)
            {
                break;
            }
            if(i==k)
            {
                flag=true;
            }
        }
        if(flag)
        {
            printf("-1\n");
        }
        else
        {
            memset(Vis, false, sizeof(Vis));
            printf("%d\n",dfs(0, 0));
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值